Avec le framework .net, installer la version la plus récente n'est pas une garantie de faire tourner les programmes.
Les logiciels écrits pour la version 1.1 ne fonctionnent pas avec les versions 2...