Affichage des résultats 1 à 5 sur 5

Discussion: [SCRIPT] Problème de lancement d'une Cutscene et d'un dialogue d'un NPC parlant

  1. #1
    Date d'inscription
    February 2014
    Messages
    79

    [SCRIPT] Problème de lancement d'une Cutscene et d'un dialogue d'un NPC parlant

    Bonjour,

    Je suis en train de tester des trucs et j'ai 2 problèmes pour le moins génant.

    1, les cutscenes, impossible de les faire fonctionner, quand l'une d'elle est censée s'enclencher, le mode cutscene démarre et rien ne se passe, le jeu se bloque quelque soit la cutscene et sa localisation (tuer un perso, téléportation, fondu au noir ect...)

    Voici à quoi ressemble mes codes:

    Code:
    IF 
      Global("!KViconiaWanted","GLOBAL",3) 
    THEN 
      RESPONSE #100 
        SetGlobal("!KViconiaWanted","GLOBAL",4)
        ClearAllActions() 
        StartCutSceneMode() 
        StartCutScene("!Kbg1vicutm") 
    END
    Placée dans le fichier script d'une créature concernée par la cutscene.

    Puis la cutscene elle même, placée dans un script nommé !Kbg1vicutm, évidemment.

    Code:
    IF 
      True() 
    THEN 
      RESPONSE #100 
        CutSceneID(Player1) 
        ActionOverride("!Kdelius",Kill(Myself))  
        EndCutSceneMode() 
    END
    Et voila, le mode cutscene démarre et plus rien. J'ai consulté tous les tutorials sur lesquelles j'ai pu mettre la main, plus les codes originaux du jeu, ça a l'air conforme, pourtant aucune de mes cutscenes ne veut marcher.

    2, Faire parler un perso non recrutable, impossible d'y arriver, j'ai suivi les tutoriaux aussi, consulté les fichiers du jeu, d'autre mods, rien à faire, mes cre se pointent et il faut toujours que ce soit mes pjs qui engagent la conversation.

    Je place un block comme ça dans le script de la créature concernée :

    Code:
    IF
      AreaCheck("AR7800")
      Global("!KViconiaWanted","GLOBAL",1)
      InParty("Viconia")
      !Dead("Viconia")
      !StateCheck(Myself,CD_STATE_NOTVALID)
      See(Player1)
      !StateCheck(Player1,CD_STATE_NOTVALID)
      CombatCounter(0)
      !See([ENEMY])
    THEN
      RESPONSE #100
        SetGlobal("!KViconiaWanted","GLOBAL",2)
        StartDialogueNoSet(Player1)
    END
    Et je mets Global("!KViconiaWanted","GLOBAL",2) comme condition de début du dialogue dans le fichier.d, et mes créatures attendent toujours bien gentiment que je clique dessus, ce qui ne le fait pas du tout...

    Des idées?
    Dernière modification par Freddy_Gwendo ; 21/03/2016 à 11h59. Motif: Modification du titre de la discussion et mise en page

  2. #2
    Date d'inscription
    April 2011
    Localisation
    Égaré dans un vortex entre Féérune et le Royaume de Diamant Éternel
    Messages
    4 202
    Désolé, je passe en coup de vent et n'ai pas le temps de me plonger dans tes codes, mais quelque chose m'a interpelé :

    Code:
    StartCutScene("!Kbg1vicutm")
    Je ne pense pas que l'IE gère les fichiers bcs composés de plus de 8 caractères...
    Essaie de changer le nom de ta cutscene en conséquence.
    CARPE DIEM...
    Co-modérateur de La Forge
    Moddeur qui s'arrache les cheveux...

  3. #3
    Date d'inscription
    February 2014
    Messages
    79
    Citation Envoyé par Freddy_Gwendo Voir le message
    Désolé, je passe en coup de vent et n'ai pas le temps de me plonger dans tes codes, mais quelque chose m'a interpelé :

    Code:
    StartCutScene("!Kbg1vicutm")
    Je ne pense pas que l'IE gère les fichiers bcs composés de plus de 8 caractères...
    Essaie de changer le nom de ta cutscene en conséquence.
    Effectivement, c'était bien ça le souci, je suis sur de l'avoir lu dans un tutorial mais ça m'était sorti de la tête. Un problème de régler, merci Freddy.

    En ce qui concerne mes cre, j'ai du déconner avec les scripts parce si je leur assigne un INITDLG du jeu vanilla, ils engagent effectivement la conversation... bon je vais reprendre les blocks concernés de zéro.

    edit: Ah, c'est bon j'ai trouvé, en suivant le modèle de INITDLG. Le 'secret' semble être d'utiliser Dialogue([PC]), à la fin du block.
    Dernière modification par Kev ; 01/07/2014 à 19h12.

  4. #4
    Date d'inscription
    April 2011
    Localisation
    Égaré dans un vortex entre Féérune et le Royaume de Diamant Éternel
    Messages
    4 202
    De rien.

    Quant à tes dialogues, consulte sur G3 le topic sur le LiellaMod dans la rubrique Modding. Son concepteur (ou plutôt sa conceptrice il me semble) a eu le même genre de problème que toi avec ses dialogues.
    C'est du en partie au type de fichiers de dialogues utilisé : banters, romances, fichier normal. Selon celui que tu utilises, il faut initier le dialogue avec une commande spéciale (Dialogue, StartDialogue, StartDialogueNoSet).
    Jastey a précisé leur utilisation selon les cas.
    Dernière modification par Freddy_Gwendo ; 01/07/2014 à 22h22. Motif: Insertion du lien de la discussion citée
    CARPE DIEM...
    Co-modérateur de La Forge
    Moddeur qui s'arrache les cheveux...

  5. #5
    Date d'inscription
    February 2014
    Messages
    79
    Citation Envoyé par Freddy_Gwendo Voir le message
    De rien.

    Quant à tes dialogues, consulte sur G3 le topic sur le LiellaMod dans la rubrique Modding. Son concepteur (ou plutôt sa conceptrice il me semble) a eu le même genre de problème que toi avec ses dialogues.
    C'est du en partie au type de fichiers de dialogues utilisé : banters, romances, fichier normal. Selon celui que tu utilises, il faut initier le dialogue avec une commande spéciale (Dialogue, StartDialogue, StartDialogueNoSet).
    Jastey a précisé leur utilisation selon les cas.
    Il est génial ce topic, j’étudierai ça tranquillement demain mais rien qu'en le parcourant, j'ai appris qu'on pouvait placer des réponses du pj aprés un block de CHAIN. (Ben non je savais pas, faut dire que c'est pas évident de trouver des tutos qui t'expliquent toutes les possibilités)
    Enfin bon, jusqu'ici mes dialogues marchent, je vais pas me plaindre.

    Merci encore.

Discussions similaires

  1. [SCRIPT] Pb avec une cutscene qui ne se lance pas
    Par Grenouillebleue dans le forum Scripts
    Réponses: 9
    Dernier message: 15/10/2009, 22h00
  2. Réponses: 4
    Dernier message: 24/08/2009, 15h10
  3. Réponses: 2
    Dernier message: 14/12/2008, 21h53
  4. Réponses: 3
    Dernier message: 08/06/2005, 21h31
  5. [SCRIPT] Ma Cutscene ne fonctionne pas...
    Par Anury dans le forum Scripts
    Réponses: 4
    Dernier message: 16/06/2004, 21h38

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249