Affichage des résultats 1 à 8 sur 8

Discussion: Installation BG1EE+BG2EE+EET+BWS+Trad FR

  1. #1
    Date d'inscription
    juillet 2018
    Messages 
    5

    Installation BG1EE+BG2EE+EET+BWS+Trad FR

    Bonjour,

    j'essaie de me faire une installation avec comme dans le titre : BG1EE, Siege Of Dragonspear, BG2EE, puis installer BWS par dessus pour télécharger les mods recommandés, ainsi que les traductions françaises.
    J'ai les versions 2.5.0.7 de BG1EE et BG2EE, et 2.4.0.6 de SOD, ce sont des versions GOG.

    J'ai testé la méthode suivante :
    - Installation de BG1EE et SOD
    - Utilisation de modmerge pour fusionner le DLC GOG sous forme d'un gros zip dans l'installation de BG1EE
    - Installation de BG2EE
    - Utilisation du tutoriel de Isaya (https://www.baldursgateworld.fr/laco...2-0-2-3-a.html (Textes et voix en français partiels - V1.2 et 1.3 ainsi que V2.0 à 2.3)) pour télécharger bg2eetrans (traduction des textes), puis une fois les textes installés, bg2eeV2.5_voixFr pour avoir aussi les voix.

    Jusque là, tout va bien : J'ai bien BG1EE en français (normal), et aussi BG2EE en français. (Merci beaucoup pour la traduction au fait !)

    Ensuite, j'utilise BWS pour installer les mods "recommandés", ainsi que EET (Trilogy pour EE) tout se déroule sans problème, mais ensuite BG2EE ne se lance plus.
    En investiguant, je vois que ça vient d'un problème de langue : Lorsque je supprime le dossier "fr_FR" des langages français dans le répertoire "lang", le jeu se lance, en anglais.

    Si maintenant je remet le dossier "fr_FR" dans le répertoire "lang" et que je sélectionne "français" dans le jeu, j'ai plein de "invalid" qui apparaissent, bref ça ne marche pas ...


    Du coup ma question : comment installer les traductions françaises (texte et voix) avec des mods ? (Je ne pense pas que le problème vienne forcément de EET mais plutôt d'un mod peut-être)

    Est-ce qu'il faut lancer les traductions une fois les mods installés seulement ?

    En observant les fichiers dialog.tlk, j'ai vu qu'il y avait quelques problèmes de textes en cp1252 (appelé souvent à tord ANSI) alors que l'encodage attendu est l'UTF8, j'ai réencodé le tout en UTF-8 à la main, mais ça n'a pas réglé le problème

    Merci d'avance pour votre aide

  2. #2
    Date d'inscription
    juillet 2003
    Localisation
    Plaisir
    Messages 
    6 990
    Bonjour,

    Je te fais une version courte, vu que l'heure d'aller dormir est déjà dépassée. Il y aura largement le temps de développer avant que les conditions ne se prêtent à ce que tu veux faire.

    Il n'y aucune chance de faire fonctionner une configuration en version 2.5 actuellement. Seul BG2EE est disponible. GOG ne bénéficie pas des versions bêta de BGEE 2.5 (à ma connaissance) et il n'existe aucune version de SoD supérieure à 2.3, sauf pour les tablettes (et dans ce cas, c'est un jeu autonome).
    Les numéros de version que tu as indiqués n'ont aucune existence officielle du côté de Beamdog. La version du patch final pour BG2EE est 2.5.16.16, la dernière bêta pour BGEE 2.5.15.1.
    BGEE et SoD ne peuvent pas fonctionner ensemble avec des numéros de version différents : il faut attendre la mise à jour des jeux pour envisager une installation avec EET.
    Peu disponible
    Guide d'installation (et FAQ) de Baldur's Gate, Baldur's Gate II, Baldur's Gate Trilogy (BGT), BG1Tutu, Widescreen, BGEE
    Pensez à utiliser à la fonction Recherche pour trouver une réponse à votre question !

  3. #3
    Date d'inscription
    juillet 2018
    Messages 
    5
    Bonjour,

    merci pour ta réponse, j'ai vérifié du coup, et ma version est une 2.3, pas 2.5... Première erreur de ma part

    Après une journée de recherche, voici où j'en suis :

    A priori il faudrait d'abord installer les patchs de langue (texte et voix) avant de lancer les autres mods (via BWS).
    L'astuce étant de lancer les patchs, supprimer ensuite le log weidu (les fichiers weidu.log dans le répertorie d'installation) pour ne pas que BWS ticke là dessus, et ensuite lancer BWS.

    Ensuite, une fois tout installé, mon BG2 ne se lançait toujours pas. J'ai essayé plein de choses (dont du code Python pour transformer l'UTF-8 défaillant en cp1252 puis re UTF-8...), ça ne marchait pas. Mais convaincu que le problème venait d'une traduction fr d'un des mods (je voyais des caractères non UTF-8 dans le fichier dialog.tlk et dès que je le supprimais ce fichier, tout marchait, mais en anglais).

    Au final, j'ai regardé quels étaient les textes où les fichiers non UTF-8 apparaissaient, et j'ai cherché des bouts de ces textes dans les archives zip des mods. Au final j'ai trouvé les bouts de textes problématiques dans le mod :
    "Gibberlings3-WheelsOfProphecy-v6-0-g4b33d77"

    Une recherche sur internet m'a permis de trouver qu'effectivement ce mod contient des textes en cp1252 (ANSI) qui ne sont pas traduits en UTF-8.
    La solution : soit désactiver ce mod, soit utiliser la solution fournie ici : http://gibberlings3.net/forums/index...howtopic=28171
    qui permet de forcer la conversion en utf-8 pour le fichier problématique.


    Je teste ça en ce moment, si ça ne marche pas, je me passerai de ce mod ...

    En espérant que je m'en sorte et que mon expérience aide un prochain utilisateur (franchement ça fait 2 jours que je suis dessus, juste pour une installation ... :/ )

  4. #4
    Date d'inscription
    juillet 2003
    Localisation
    Plaisir
    Messages 
    6 990
    C'est plutôt une bonne nouvelle que tu aies la version 2.3. Au moins tu pourras installer EET avec beaucoup plus de certitude que cela va fonctionner. L'auteur d'EET est absent depuis de nombreux mois, il n'est donc pas certain qu'il fonctionnera parfaitement avec la version 2.5. Tu as sans doute intérêt à ne pas faire de mise en jour.

    Je confirme qu'il faut bien que tu installes le mod de traduction en premier. Sinon EET n'aura pas de langue française à laquelle ajouter les textes français de BGEE, d'EET et des autres mods. Pour les voix, tu dois pouvoir les ajouter plus tard sans conséquence.
    J'ignorais qu'il ne fallait pas de WeiDU.log pour que BWS fonctionne. Si le BWS supporte le français, ce serait intéressant qu'il référence le mod de traduction comme premier mod à installer. Je note de le contacter à ce sujet, lorsque j'aurai du temps de libre.

    Même si la liste n'est pas exhaustive, n'hésite pas à consulter le sujet de la liste de mods disponibles pour BG2EE pour avoir une idée des mods déjà prêts pour BG2EE ou moyennant une manipulation (décrite) pour passer en UTF8. J'y ai aussi indiqué la manipulation à faire pour Wheels of Prophecy. J'avais vérifié qu'elle fonctionnait (c'est à dire que les textes étaient bien convertis, pas que cela fonctionnait parfaitement dans le jeu), je ne vois pas de raison qu'il y ait un problème (ou alors à cause d'un bug du jeu ou d'un mod).
    En pratique il ne doit pas y avoir beaucoup de mods avec traduction française et annoncés comme compatibles avec BG2EE qui ne figurent pas dans la liste (même si je ne l'ai pas rafraichie au rythme de traduction de Freddy_Gwendo). Pour les mods non traduits, c'est loin d'être vrai.

    J'espère que ton installation a bien tourné. Vu les investigations que tu as faites, il y a de bonnes chances que tu aies levé les obstacles.
    Peu disponible
    Guide d'installation (et FAQ) de Baldur's Gate, Baldur's Gate II, Baldur's Gate Trilogy (BGT), BG1Tutu, Widescreen, BGEE
    Pensez à utiliser à la fonction Recherche pour trouver une réponse à votre question !

  5. #5
    Date d'inscription
    juillet 2018
    Messages 
    5
    Hello,

    c'est bon, enfin !

    Et c'était bien Wheels of prophecy le problème, et après la manip de faite, tout marche !

    En plus c'était effectivement indiqué dans ta liste de mods disponible, la manip à faire, je n'y avais pas vu

    Pour BWS, en fait le problème c'est que l'installation des mods de BG2 débute par un point de backup. Si l'on utilise le patch bg2eetrans (le tiens je crois?) pour créer les textes français, ça crée un log weidu dans le répertoire d'installation de BG2EE. Et lorsque BWS essaie de créer un backup, il part de l'hypothèse que le répertoire de BG2EE est une installation clean et fraiche sans aucun mod. Lorsqu il rencontre un log weidu non vide, il bug car il trouve donc qu'un mod a déjà été installé.
    La solution donc : installer bg2eetrans, supprimer les 2 fichiers weidu qu'il aura créé, et installer BWS.

    Pour wheels of prophecy, en fait le problème était qu'il était dans la liste verte de BWS (les mods censés s'installer sans problème et sans manip de ce que j'avais compris). Du coup il devrait plutôt changer de couleur (pour les utilisateurs avertis). Là, la soluce que j'ai utilisé, c'est d'utiliser BWS pour télécharger tous les mods, ensuite avant de passer à la suite dans BWS (installation des mods), on dézippe le wheels of prophecy téléchargé par BWS, on édite le fichier TL2 avec la manip évoquée, et sauvegarde, et on rezippe le tout. (Il faut faire ça seulement après que BWS ait téléchargé le mod, sinon j'ai l'impression qu'il se rend compte que le zip de wheels of prophecy n'a pas la bonne taille, et il y retélécharge, ce qui effacerait la manip si on y faisait avant le téléchargement). Ensuite on lance l'install normalement.


    Merci beaucoup pour ton aide en tout cas ! En espérant que mes galères pourront aider un futur débutant comme je l'étais il y a 2 jours

  6. #6
    Date d'inscription
    juillet 2018
    Messages 
    5
    Bonsoir,

    j'ai à nouveau un problème, dans le jeu cette fois

    Certains sorts de mages font freezer le jeu : plus rien ne répond, obligé de couper le jeu de force avec le gestionnaire de taches.

    En cherchant un peu, cela semble venir du mod SCS. Ca fait que par exemple, dès que l'on essaie de combattre silke à beregost, dès le premier sort qu'elle lance, le jeu freeze ...

    Cette fois j'ai directement pensé à la liste de compatibilité des mods d'Isaya : Il semble qu'il faille patcher SCS. Mais après recherche vers le lien, il semble que les patchs servent à faire réussir l'installation de SCS. Dans mon cas, l'installation a bien réussi (du point de vue de weidu), c'est ensuite dans le jeu que lors de certains sorts, le jeu freeze ...

    Dans mon cas, j'ai résolu le problème en désinstallant le premier composant de SCS relié aux sorts : Protection contre les projectiles normaux bloque également les fleches de feu/froid/acide et projectiles similaires sans bonus. Je ne sais pas trop si c'était ce composant qui faisait vraiment buguer, ou si c'est juste que la désinstallation a changé quelque chose ailleurs ...

  7. #7
    Date d'inscription
    avril 2011
    Localisation
    Égaré dans un vortex entre Féérune et le Royaume de Diamant Éternel
    Messages 
    5 864
    Il me semble que de nombreux joueurs se sont plaints sur le forum Beamdog de l'incompatibilité de SCS avec le patch 2.5. Tu devrais aller y jeter un œil pour voir si une solution n'a pas été trouvée.
    CARPE DIEM...
    Co-modérateur de La Forge et de La Chambre des Scribes
    Moddeur qui s'arrache les cheveux...

  8. #8
    Date d'inscription
    juillet 2018
    Messages 
    5
    en réalité c'est même avec la version 2.3 que SCS faisait buguer mon jeu ...

    Une fois le composant de SCS qui posait problème enlevé, tout va bien

Discussions similaires

  1. [BG2EE] [MOD] Installation du mod Baldur's Gate EET
    Par Oldereign dans le forum BG2:EE
    Réponses: 13
    Dernier message: 05/04/2018, 12h51
  2. [BG2EE][TECH] Impossible de redémarrer BG2EE après installation de mods…
    Par Prof Errata dans le forum BG2:EE
    Réponses: 3
    Dernier message: 21/08/2017, 11h42
  3. Présentation du projet de trad de BG2EE
    Par Graoumf dans le forum Traduction participative de BG2EE
    Réponses: 6
    Dernier message: 11/05/2017, 23h52
  4. [BG1EE][TECH] Bug au lancement de BG1EE et de BG2EE
    Par alliaume dans le forum BG1:EE
    Réponses: 4
    Dernier message: 30/04/2016, 14h30
  5. [BG2EE] Installation de mod pour BG2EE
    Par Umbre dans le forum BG2:EE
    Réponses: 2
    Dernier message: 09/04/2015, 21h32

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252