Affichage des résultats 1 à 6 sur 6

Discussion: [BGT] Problème d'installation - pas de disque dans le lecteur

  1. #1
    Date d'inscription
    August 2005
    Messages 
    191

    [BGT] Problème d'installation - pas de disque dans le lecteur

    Bonjour à tous.


    Je viens de finir ma première partie de BGT, et je souhaite en faire une nouvelle. Pour faire les choses proprement, j'ai décidé de tout désinstaller et réinstaller. J'ai d'abord désinstallé et réinstallé Baldur's Gate I et II (Pour les installations, j'ai suivi les instructions données dans le sujet [BGT] Baldur's Gate Trilogy-WeiDU.

    Maintenant je veux installer BGT, mais j'ai un problème. J'ai enlevé le cd de BG de mon lecteur (et j'ai vérifié que mon lecteur virtuel est vide également) avant de lancer l'installation comme recommandé. L'installation commence, mais rapidement après avoir donné le path de BGI, un message d'erreur apparait : "Pas de disque dans le lecteur". Il s'agit d'un problème décrit dans le read-me de BGT.

    Minor Installation Errors

    During the installation, I constantly get errors saying ‘There is no disk in your drive’.
    This occurs if you did not follow Step 2 of the installation procedures.

    • If you have not installed yet, or as you read this the installation is halted directly after you were asked to enter your Baldur's Gate and Tales of the Sword Coast directory with the disk check, abort the installation immediately.
    • As you read this, if the installation is halted any time after you were asked to enter your Baldur's Gate and Tales of the Sword Coast directory, press 'Cancel' to every single prompt that occurs, and allow the installation to finish. When the installation is finished, uninstall BGT-WeiDU and restore dialog.tlk.
    • Follow the installation procedures correctly without omitting Step 2.
    Je vais donc voir quel est ce step 2 que je n'ai pas suivi:

    1. Run Setup-BGT.exe in your Baldur's Gate II install directory and follow the installation prompts
      • Windows 9x/ME users: When prompted for Baldur’s Gate I installation, type in the appropriate path without any terminal slashes, then press Enter
      • Windows NT users: When prompted for Baldur’s Gate I installation, type in the appropriate path without any terminal slashes, press Ctrl+z, then Enter
      • Windows 2000/XP/Vista users: When prompted for Baldur’s Gate I installation, type in the appropriate path then press Enter



      The installation checks that the Baldur's Gate I installation directory you typed contains a full custom installation of Baldur's Gate and Tales of the Sword Coast. If the installation needs to be aborted to correct your Baldur's Gate I installation, you can safely close the installation window or press Ctrl+Break three times.
    (La quote a changé le numéro en 1, mais c'est 2 dans le read-me )

    Là je ne comprends pas trop. L'étape 2 consiste à lancer BGT-setup, et à encoder le path de BGI. L'explication du message d'erreur sous-entend que je n'ai pas fait cela. Pourtant, j'ai bien lancé le setup (forcémment, sinon je n'aurais pas d'installation), et j'ai encodé le bon path (en tout cas, l'installation à l'air de trouver les fichiers de BGI dans ce path).

    Quelqu'un aurait-il une explication à ce phénomène?

    Merci d'avance de vos réponses.

    Edit - J'ai mis un cd au hasard (Bioshock si vous voulez vraiment savoir ) dans le lecteur, de manière à ne plus être importuné par les "pas de disque dans le lecteur". L'installation s'est poursuivie jusqu'à son terme sans avalanches de messages d'erreur, et le jeu à l'air de fonctionner normalement (création d'une nouvelle partie de BGI: ok). Je préfèrerais quand même avoir une installation vraiment clean avant de commencer à jouer...
    Dernière modification par Avatar ; 07/03/2009 à 14h31.
    Arpenteur de l'espace B

  2. #2
    Avatar de Vel Cheran
    Vel Cheran est déconnecté a du RP en retard
    Date d'inscription
    December 2007
    Messages 
    2 107

    Re : [BGT] Problème d'installation - pas de disque dans le lecteur

    As-tu pensé à lancer une partie de BG2 au moins une fois avant d'installer BGT ?

  3. #3
    Date d'inscription
    August 2005
    Messages 
    191

    Re : [BGT] Problème d'installation - pas de disque dans le lecteur

    Maintenant que tu le dis, j'avais effectivement oublié de lancer une partie avant d'installer BGT

    Cependant, ce n'est pas la raison du problème. J'ai désinstallé et réinstallé BG2, j'ai lancé une partie de ToB avant d'installer BGT, mais j'ai toujours le même message d'erreur si mon lecteur DVD est vide.

    Je crois que je vais continuer avec cette installation qui a l'air (au premier abord) de fonctionner quand même. Espérons que de vilains bugs ne se manifestent pas par la suite...
    Arpenteur de l'espace B

  4. #4
    Date d'inscription
    November 2002
    Localisation
    Entre nulle part et partout.
    Messages 
    2 309

    Re : [BGT] Problème d'installation - pas de disque dans le lecteur

    J'ai décidé de réinstaller BGT, et je suis tombé face au même problème. J'ai trouvé d'autres problèmes en cascade : PNJ qui refusent de me parler parce que "ils sont occupés à quelque chose d'autre", ou pire, la carte qui est celle de BG2 alors que je viens de démarrer une partie de BG1. Je suis ouvert aux suggestions.

    [Edit] J'avais le CD de Bioshock sous la main, j'ai testé, cette méthode marche. Merci pour ce morceau de sagesse, Avatar.
    Dernière modification par Agifem ; 21/04/2009 à 08h58.
    Agifem, Auteur des Chroniques de l'Age Sombre, mordeur des titreurs négligeants, molosse modérateur du forum NeverWinter Nights 1, et Tyran Suprème du forum NeverWinter Nights 2.

    Un dernier merci à Egrevyn, mon ami, pour tout ce que tu as fait pour nous tous.

  5. #5
    Date d'inscription
    March 2011
    Localisation
    Amiens
    Messages 
    1
    Bonjour/Bonsoir à tous,

    Je me permets de remonter ce topic plutôt que d'en créer un nouveau, car je rencontre le même problème qu'Avatar. Le fait de cliquer continuellement sur "continuer" ou "annuler" permet à l'installation de se dérouler normalement, du moins en apparence (pour ce qui est de l'insertion d'un quelconque CD, je n'ai pas vérifié), mais étant parano de nature, je me demandais s'il y avait possibilité d'avoir quelques témoignages de gens ayant eu ce problème. Ma pire crainte est de démarrer une partie normalement pour me retrouver avec de gros bugs insolubles quelques heures de jeu plus tard... J'ai lancé le jeu (en commençant une partie de BG1) pour tester tout à l'heure; tout a bien fonctionné, si ce n'était que mon personnage avait deux fois plus de points de vie qu'il n'aurait dû. Je ne sais pas si c'est un bug connu ni s'il est lié à ce problème, mais je le signale à tout hasard.

    Je précise que j'ai suivi à la lettre la procédure d'installation décrite dans ce fil et que je possède BG1+TotSC en version 6 CD et BG2+ToB en version 5 CD (les deux versions d'origine, en somme). Je n'ai installé aucun mod si ce n'est BGT et le FixPack, comme l'atteste le contenu de mon WeiDU.log:

     Cliquer ici pour révéler le texte


    J'ai également désactivé mon anti-virus durant l'installation à tout hasard, mais les demandes de CD reviennent systématiquement. J'aimerais donc savoir si cela entraine de réels problèmes par la suite ou non.

    Merci d'avance.

    EDIT: j'avais également eu une demande de CD durant l'installation du BG2 Fixpack, dont je n'ai pas réussi à savoir si elle était normale ou non, n'ayant pu trouver aucune information allant dans un sens ou dans l'autre. Toujours est-il que l'installation s'est apparemment poursuivie normalement lorsque j'ai inséré le CD de ToB.
    Dernière modification par Minimage ; 18/12/2011 à 00h32.

  6. #6
    Date d'inscription
    December 2007
    Localisation
    paris
    Messages 
    247
    Bon je me permet aussi de m'engouffrer dans la "nécro" de Minimage pour lui répondre vu que j'ai eu de mon côté à subir ce type de problème lors de la mise en place d'une méga install qui m'a pris plus de deux semaines tellement elle était grande et aussi parce que j'ai mer.... à plusieurs reprises oubliant ceci ou celà ou installant des mods qui s'avèraient en fait inintéressants... (j'ai un boulot + femme et enfants donc je peux pas y passer des journées complètes mais il y a plusieurs dizaines d'heures à coup sûr !).
    A deux reprises lors d'une installation foirée et en tentant une nouvelle installation après j'ai eu des demandes de cd systématiques alors qu'il me semblait avoir suivi le protocole à la lettre. Je suis sous Windows Vista. Je me suis alors aperçu qu'il ne fallait pas seulement tout désinstaller et effacer l'ensemble du contenu du dossier de répertoire accueillant la méga install (ex : C:\Users\mon nom\ BG Games\SOA) dont BGT. Non, il faut aussi effacer entièrement le contenant c'est à dire le dossier de répertoire lui même (ici dans l'exemple c'est le dossier "SOA"). Et la j'avais un message qui m'interdisait de le faire comme quoi l'application était ouverte ailleurs ou quelque chose comme ça. Et j'étais pourtant en mode administrateur. En redémarrant mon PC je pouvais enfin effacer complètement ce fameux dossier.
    Et la je pouvais dire que j'avais une désinstallation entièrement clean. Ensuite il me suffisait de recréer mon dossier de répertoire d'installation et de recommencer ma méga install comprenant BGT.
    Donc assurez vous bien lors d'une nouvelle installation, d'avoir avant tout, entièrement effacé toute traces de l'ancienne. Et au passage l'emploi d'un utilitaire de nettoyage de clés de registre inutiles ne peut pas faire de mal. Contrairement au proverbe ici il faut jeter non seulement l'eau du bain mais aussi le bébé avec...
    Si la bêtise était côtée en bourse. Nous serions cernés par les multimilliardaires...

Discussions similaires

  1. [TDD] Problème d'installation
    Par Non inscrit dans le forum Méga-mods : Big Picture, The Darkest Day, Shadow Over Soubar, Tortured Souls, Check The Bodies, Nev
    Réponses: 6
    Dernier message: 13/11/2008, 21h07
  2. [TECH] Vista me demande le CD de ToB alors qu'il est dans le lecteur
    Par Nightmare dans le forum La Taverne d'Amkethran (Baldur's Gate 2)
    Réponses: 5
    Dernier message: 12/04/2008, 16h03
  3. [BG1] Problème d'installation
    Par Seigneur des anneaux dans le forum La Taverne de Château-Suif (Baldur's Gate 1)
    Réponses: 10
    Dernier message: 08/12/2007, 22h38
  4. [TOB] Problème d'installation..
    Par ArTi dans le forum La Taverne d'Amkethran (Baldur's Gate 2)
    Réponses: 3
    Dernier message: 14/09/2007, 20h13
  5. [BGT] Probleme d'installation
    Par Wisper dans le forum Baldur's Gate Reloaded : les mods TUTU et Baldur's Gate Trilogy
    Réponses: 2
    Dernier message: 25/07/2007, 00h17

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250